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Current Release Notes - Quantrix Modeler 

  

Quantrix Modeler 19.1.0 

  

Important note for Qloud Enterprise users: Quantrix Modeler 19.1.0 is incompatible with Qloud 
versions less than 19.1.0. 

  

Improvements in Version 19.1.0 

19.1.0 introduces a major redesign of DataNAV, now called Data Import. The Data Import design 
provides a much better, easier user experience for configuring and querying data sources. Data 
Import includes a new user interface for the data source configuration and the set up of the data 
matrix. 

The Data menu is redesigned and optimized, and includes new menu options to support the new Data 

Import feature. Sort and Filter now have their own submenus (QM-23111) 

 

  

A new Data Browser menu option opens a three-tabbed Data Browser pane showing you all data 
import sources and queries in your models. You can export, import, edit, add them to the current 
model, create new import matrices from sources, and update all or selected data sources and queries 
(QM-22298)  

https://quantrix.com/help_resources/modeler/webhelp/#t=Import_Data.htm
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Data Browser Model Data Browser Library Data Browser From File 

 

 
   

   

   

   

   

   

   

  

 
   

   

   

   

   

   

   

  

  

Icon Description 

 

Data Source  

 

Query (in the model) 

 

Query (in the Library and From File 

tabs, and available to add to the 

model) 

  

You can easily find information on data sources and queries by hovering: 
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From several locations in Data Import there are right-click Context menus, some of which are shown 
below: 

 

 

  

 

 

 

  

The former DataNAV functionality is rolled into the new Import Data feature. The Data > Import Data 

menu lets you choose the type of data based on its source such as Database, Matrix, Salesforce, Text 
File (Delimited or Fixed), and XML.  
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Configuring a data source is much faster, requiring fewer steps and clicks (QM-22290). From within 
configuration, you can easily access the data source configuration, the data source data tree and 
import matrix configuration, and the data import matrix.  Please see the help for details.  

For models containing Legacy SQL data sources that have more than one master table, you will be 
prompted upon opening the model to choose whether you want the model (including all its data 
sources) to be converted for import. If you choose Yes to convert, the data sources are assigned to 
different data import matrices. If there are many data sources in a model, and you don't plan to use 
them all, you may save conversion time by answering No to the import conversion prompt, and then 
editing the data sources you plan to use. When you save, only the edited data sources are converted 

(QM-22787) 

Indented below are improvements related to the data operations redesign. Please read the webhelp 
for details of Import Data: 

Categories created in Data Import can be dragged, dropped and linked to other matrices, including 
to other Data Import matrices provided certain rules are met. When dragged to non-Data Import 
matrices they can be used to convert the matrix to a Data Import matrix using the same data 
source as the dragged data import category (QM-23055)  

When a data source is used in multiple matrices and the data source is edited, all matrices that 
use that data source are updated (QM-22804) 

Import Data > Matrix Data includes a new option to use a Qloud Model as the data source 
(QM22622) 

Data Import determines data types with improved accuracy (QM-18282) 

Data Import of fixed width files has been improved to analyze and skip rows when needed to 
correctly import the data (QM-19127), and uses an improved algorithm to determine field widths 
(QM-22361)  

The data source tables and fields are now shown as a tree with icons indicating data type (QM-

22302). At the top of the data source tree are tools including a Quick Find, Refresh, Edit 
Configuration, and icon buttons to show only specific data types (QM-22445).  

A new Configure Database pane (QM-22293) lets you use custom SQL to define a database data 
source by clicking a new Query using SQL link (QM-22297) 

Certain data sources now provide a First/Last summarizer that will bring in the first or last value 
seen in the data for a cell in the matrix (QM-22463)  

Data Import allows you to select one or more fields in the data source tree and use a right-click 
option to create one or more import item descriptors and populate the item descriptor values in 
the matrix area (QM-22289)  See Known Issues. 

Data Import lets you easily toggle back and forth between the configuration and imported data 
matrix by clicking icon buttons (QM-23066) 



Modeler Release Notes 

5 

Data Import lets you drag and drop fields onto a Filter pane, select comparison operators to 

potentially operate on user-entered Values, other Fields or Expressions to effectively Filter the 
data, and you can combine multiple filters in a Filter Logic pane (QM-22304, QM-18492, 
F0057109). 

Writing expressions in Data Import Filters is much easier in Data Import, and you can build and 
change expression filters in the new filters section of the Configure data matrix (QM-18494, 

F0058046) 

Data Import lets you drag and drop the import table fields to configure data on a matrix preview 

pane as data items, categories and groups (QM-22448) 

You can now create Groups from Data Import (QM-18498). Data Import lets you create groups 
automatically by dragging and dropping table fields (QM-18535), and you can manually create 

groups of items.  See Webhelp for details.  See Known Issues. 

You can now set summarization methods on multiple items at once rather than on one at a time: 

A Summarizer context submenu for data item selections and summarizer item descriptor 

selections now appears for single and multiple selections that have at least one summarizer in 
common (QM-3510) 

Permissions are updated to support Data Import (QM-22395) 

Quantrix now displays the absolute path rather than a relative path in Data Import and DataLink 
to improve usability and reduce confusion (QM-20921) 

Options/Preferences for Database drivers (Tools > Options > Data > Database (JDBC) and Import 
Data > Database > Connect to > Add New Database have  been redesigned to make it easy to 
add, edit and remove drivers and multiple versions of driver types, and to see and select driver 
versions in saved data connections (QM-22738, QM-22837, QM-22839). Driver versions are 
shown, and duplicate drivers are detected.  See related Known Issue. 

You can now easily view and edit the database name and the driver description of an existing 
database driver using Tools > Options > Data > Database (JDBC) using the Edit pencil (QM-
11864) 

The Salesforce Data Import preview pane and data grid now show the same column labels. Labels 
show in the Data tree, item/category names and field names in the filter panel; labels show in the 
Data Source tree, and the item/category names and the field names show in the filter panel. You 
can set the labels in Text file data sources in the data source configuration pane, although they 

may be overwritten if you edit the source or refresh. Column labels are fixed in Database data 
sources and Salesforce data sources: all other sources have a label based on the name (QM-
20498)  

The legacy 1.1 database driver for H2 has been removed from the Configure Database panel. 
Previously configured DataLinks, DataNAVs and DataPushes that were created using 1.1 will give a 
'driver not found' error and will need to be updated (QM-22410) 

Due to deprecation by major products/vendors, and Quantrix surveys indicating disuse, SOAP is 
no longer a supported data type for import (QM-22290) 

  

Modeler now supports the selection and insertion/ placement of scalable (.SVG) images in cells and on 
canvases using the same menus and toolbars used with other image file formats, and SVG files can be 
dragged and dropped as SVG files, and dragged within, Modeler (QM-22903, QM-22902) 

Solver now supports running multiple solver configurations at once using a new right-click pop-up 
menu option called Run Solver. Run Solver will run any number of saved configurations in a cell 
selection. See the webhelp for details (QM-22740) 

A Java library, Quaqua, used in Quantrix for MAC look and feel, has been removed because it is no 
longer supported: MAC users may notice a slight difference in file chooser operations (QM-22633) 
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A new Permission has been added to control which roles can view an audit trail. Use Permissions > 

Allow Interaction > View Audit Trail to restrict viewing of audit trail by role (QM-22434)  

To support data security, the option to save and open model files in .xml format, which is unencrypted 
plain text, has been removed. Models can no longer be saved or opened in .xmodel format (QM-
22655) 

You can now add an unlimited number of items to a category at once, up to the cell limit for the 

matrix. With an item selected, you can open the Insert Items dialog using the right-click menu, the 
Insert menu or Alt-I-N (QM-22809) 

Error handling has been improved regarding jdbc drivers so that if Quantrix encounters an invalid jdbc 
driver configuration file an error is written to a log file and the user sees a Driver not found message 
(QM-21929) 

The Timeline Start Date now defaults to the current year (QM22890)  

Significant Fixes in Version 19.1.0 

Text files with a digit in the first character are now correctly given a type of text during import, rather 
than double (QM-18281) 

An exception no longer occurs during data operations (Data Import, DataLink, DataPush) when the 
authorization file is removed or corrupt: the user is prompted to log in again (QM-19677) 

When importing from a delimited text file, the option to coalesce consecutive delimiters no longer 
displays extraneous characters such as quotes (QM-19022) 

The fixed width screen font can no longer be changed, which ensures that the preview pane displays 
the data and field boundary lines appropriately (QM-21944) 

CSV files containing multi-line headers (headers containing new line characters), or multi-line data, 

are now imported correctly to the header or cell (QM-21957) 

Changes to a Data Source that is used in multiple matrices now opens the Configuration Problem 
panel with options to fix the affected matrices. This applies to editing the data source and  refreshing 

a data source that has changed structure (QM-18496) 

The version of Java used on Windows is updated to Java 8u172, which resolves a Japanese font 
rendering issue; OS X remains at Java 8u92 (QM-22686) 

OSX now uses the date format from system settings when you browse and use the Open dialog to 
open a model (QM-18698, F0064488) 

Script hotkeys are no longer removed when models containing scripted buttons are saved and 
reloaded (QM-22823) 

Expressions created in SQL are now supported in Database Data Sources (QM-22810, F0105162) 

An exception should no longer occur in Data operations (Data Import, DataNAV) such as adding, 

removing or moving categories (QM-22574) 

On OSX, Quantrix now dynamically detects and maximizes to the correct size when a display is 
connected during a session (QM-19201, F0068700) 

On OSX when using matrices detached from the model, the menu bar in the primary display no longer 
loses menu options when you give focus to a matrix in the second display (QM-18978) 

A calculation anomaly that occurred in specific scenarios involving lookups in multiple matrices and 
copying items no longer incorrectly changes cell values on recalcDue to a change in the layout of 
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matrix views, the maximum size of a matrix view in a canvas is now 32,000 pixels. The work around is 

to make the matrix view scrollable if there are more than 2000 rows or columns in the matrix. (QM-
22950) 

An exception should no longer occur that related to roles, permissions, canvases and adding/deleting 
components, such as adding a new item to a category (QM-22960, QM-19657, SW0030029) 

Timeline Summary item names for a Year category can now be changed provided the user has 

permissions to rename items (QM-22882, F0105162) 

Timelinedate() now handles dates correctly for Fiscal years that use an "other" configuration of days 
(QM-22742)  

Timelinedate() now accounts correctly for summary items and time ranges and calculates correctly 
(QM-22915, F0105326, F0105809)  

When using the Insert Image dialog, closing the dialog using the "X" now correctly closes out without 
inserting the image (QM-19162) 

When inserting images, images are no longer showing twice in the image pane or image dialog box 
(QM-21554) 

Drag and drop of images from a website or from another application now works correctly (QM-22931) 

An issue in DataNAV Qualifier wherein Date formatted values showed as integers no longer occurs in 
the Data Import Qualifier Pane feature (QM-22983, F0099413) 

A DataNAV drill down error that occurred where grouping created a integer type value but the drill 
down expected a double type no longer occurs in Data Import (QM-22525, F0099415) 
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Known Issues in Version 19.1.0 

Due to the removal of the unsupported Java library, Quaqua, MAC users may see an erroneous 
overwrite message if you select a non-model file in the Save As dialog: the file will not be overwritten 
because Quantrix will append a .model extension to the selected file (QM-22577) 

Users who click Next from the Updater Comments dialog may get an error downloading. If this occurs, 

please exit, start again and install from the main Updater dialog rather than the Comments dialog 
(QM-22821) 

Users who have multiple and incremental versions of the same database driver may want to remove 
the older version prior to adding a new one to eliminate confusion when selecting named/saved 
Connections in Import Data > Database (QM-22837) 

You cannot set Item Descriptors for the All Rows category (QM-22854), and imported Item Descriptors 
do not currently support number/date formats (QM-22855) 

Group names with the same name at different group levels may have unpredictable names (QM-
22784)   

In Data Import, Add Custom field to Join tables is currently disabled (QM-22528) 

In Data Import, the use of Date Field quantizers to create drill down matrices is not currently 
supported (QM- 23121) 

Dropping text onto a canvas currently results in a blank text object (QM-22933) 

Due to a change in the layout of matrix views, the maximum size of a matrix view in a canvas is 
32,000 pixels. If there are more than 2000 rows or columns in the matrix, turn on scroll bars so you 
will be able to scroll to all areas of the matrix (QM-23112) 

The Library and Export options are not currently available for Salesforce Data Sources (QM-23166) 

When you use a legacy DataNAV in Data Import that has the All Rows category, and you take certain 
actions such as Edit, the All Rows category may be removed: to reset it, re-select All Rows in the Data 
Import Data tree (QM-23204) 

  

  

  

  

  

  

 


